abstract-leveldown travis-ci npm

a base "class" for implementing a leveldown compatible API