angular2-slickgrid gulp npm

SlickGrid with Angular2 wrapper and virtualized data support.

2 years after

Set up Node, npm, gulp and typings

Node and npm

Windows and Mac OSX: Download and install node from nodejs.org

Linux: Install using package manager

From a terminal ensure at least node 5.4.1 and npm 3:

$ node -v && npm -v
v5.9.0
3.8.2

Note: To get npm version 3.8.2, you may need to update npm after installing node. To do that:

[sudo] npm install npm -g

Gulp

Install gulp

[sudo] npm install gulp -g

From the root of the repo, install all of the build dependencies:

[sudo] npm install --greedy

Typings

Install Typings CLI utility

npm install typings --global

Install required typings to build this project

typings install

Build project

Type gulp build from the command line or run build inside VSCode


Top Contributors

anthonydresser Raymondd coquagli kburtram kevcunnane

Releases

-   1.3.2 zip tar
-   1.3.1 zip tar
-   1.3.0 zip tar
-   1.2.4 zip tar
-   1.2.3 zip tar
-   1.2.2 zip tar
-   1.2.1 zip tar
-   1.2.0 zip tar
-   1.1.0 zip tar
-   1.0.0 zip tar