grunt-wp-i18n travis-ci grunt npm

Internationalize WordPress themes and plugins with Grunt.

grunt-wp-i18n Build Status

Internationalize WordPress plugins and themes.

WordPress has a robust suite of tools to help internationalize plugins and themes. This plugin brings the power of those existing tools to Grunt in order to make it easy for you to automate the i18n process and make your projects more accessible to an international audience.

If you’re not familiar with i18n concepts, read the Internationalization entries in the Plugin Developer Handbook or Theme Developer Handbook.

Getting Started

If you haven’t used Grunt before, be sure to check out the Getting Started guide, as it explains how to create a Gruntfile as well as install and use Grunt plugins. Once you’re familiar with that process, you may install this plugin with this command:

npm install grunt-wp-i18n --save-dev

Once the plugin has been installed, it may be enabled inside your Gruntfile with this line of JavaScript:

grunt.loadNpmTasks( 'grunt-wp-i18n' );

Requirements

  • This plugin requires Grunt ~0.4.0.
  • PHP CLI must be in your system path.

Tasks

This plugin consists of two configurable tasks:

Related Repositories

grunt-wp-i18n

grunt-wp-i18n

Internationalize WordPress themes and plugins with Grunt. ...


Top Contributors

bradyvercher GaryJones andreg ntwb shivapoudel atimmer marcochiesi walbo rdoursenaud shakyShane claudiosanches

Releases

-   v0.5.4 zip tar
-   v0.5.3 zip tar
-   v0.5.2 zip tar
-   v0.5.1 zip tar
-   v0.5.0 zip tar
-   v0.4.9 zip tar
-   v0.4.8 zip tar
-   v0.4.7 zip tar
-   v0.4.6 zip tar
-   v0.4.5 zip tar
-   v0.4.4 zip tar
-   v0.4.3 zip tar
-   v0.4.1 zip tar
-   v0.4.0 zip tar
-   v0.3.1 zip tar
-   v0.3.0 zip tar
-   v0.2.0 zip tar
-   v0.1.0 zip tar