iugu-php Packagist

iugu - Biblioteca para PHP

3 years after

Iugu para PHP

Requisitos

  • PHP 5.4+

Instalação

Faça o download da biblioteca:

git clone https://github.com/iugu/iugu-php

Inclua a biblioteca em seu arquivo PHP:

require_once(".../iugu-php/lib/Iugu.php");

Usando Composer

$ composer require iugu/iugu
Please provide a version constraint for the iugu/iugu requirement: 1.0.6

O autoload do composer irá cuidar do resto.

Exemplo de Uso

Iugu::setApiKey("c73d49f9-6490-46ee-ba36-dcf69f6334fd"); // Ache sua chave API no Painel

Iugu_Charge::create(
    Array(
      "token"=> "TOKEN QUE VEIO DO IUGU.JS OU CRIADO VIA BIBLIOTECA",
      "email"=>"[email protected]",
      "items" => 
      Array(
        Array(
          "description"=>"Item Teste",
          "quantity"=>"1",
          "price_cents"=>"1000"
          )
        )
      )
    );

Documentação

Acesse iugu.com/documentacao para referência

Testes

Instale as dependências. Iugu-PHP utiliza SimpleTest.

composer update --dev

Execute a comitiva de testes:

php ./test/Iugu.php

Related Repositories

restinga

restinga

Easily Create REST API Clients for your PHP Applications ...


Top Contributors

pnegri filpgame vFragosop paezao flaviozantut wemersonjanuario

Releases

-   1.0.6 zip tar
-   1.0.5 zip tar
-   1.0.4 zip tar
-   1.0.3 zip tar
-   1.0.2 zip tar
-   1.0.1 zip tar
-   1.0.0 zip tar
-   0.1.0 zip tar
-   0.0.6 zip tar