League\Flysystem\AwsS3v3

Author Build Status Coverage Status Quality Score Software License Packagist Version Total Downloads

This is a Flysystem adapter for the aws-sdk-php v3.

Installation

composer require league/flysystem-aws-s3-v3

Bootstrap

<?php
use Aws\S3\S3Client;
use League\Flysystem\AwsS3v3\AwsS3Adapter;
use League\Flysystem\Filesystem;

include __DIR__ . '/vendor/autoload.php';

$client = new S3Client([
    'credentials' => [
        'key'    => 'your-key',
        'secret' => 'your-secret'
    ],
    'region' => 'your-region',
    'version' => 'latest|version',
]);

$adapter = new AwsS3Adapter($client, 'your-bucket-name');
$filesystem = new Filesystem($adapter);

Related Repositories

flysystem-aws-s3-v3

flysystem-aws-s3-v3

Flysystem Adapter for AWS SDK V3 ...

flysystem-aws-s3-v3

flysystem-aws-s3-v3

Flysystem Adapter for AWS SDK V3 ...


Top Contributors

frankdejonge GrahamCampbell zaak svycka janhartigan DemonTPx iansltx CarsonF kaysersoze aarondfrancis twistor jeremeamia foaly-nr1 jimbojsb philsturgeon sdsomma tamc yellow1912

Releases

-   1.0.13 zip tar
-   1.0.12 zip tar
-   1.0.11 zip tar
-   1.0.10 zip tar
-   1.0.9 zip tar
-   1.0.8 zip tar
-   1.0.7 zip tar
-   1.0.6 zip tar
-   1.0.5 zip tar
-   1.0.4 zip tar
-   1.0.3 zip tar
-   1.0.2 zip tar
-   1.0.1 zip tar
-   1.0.0 zip tar